Tycho
Welcome, Guest
Please Login or Register.    Lost Password?
XML no element found (1 viewing) (1) Guest
Go to bottom Post Reply Favoured: 0
TOPIC: XML no element found
#24
XML no element found 11 Years, 2 Months ago  
Getting this response when trying to debug Tycho via a browser:

XML Parsing Error: no element found
Location: http://default%2f501:[redacted]@[my server]/voicemail/voicemail.php?action=listfoldercontent&folder=INBOX
Line Number 2, Column 1:

Any ideas what's wrong here?

Thanks!
Enter code here   
Please note, although no boardcode and smiley buttons are shown, they are still useable
 
Report to moderator   Logged Logged  
  Reply Quote
#25
Re:XML no element found 11 Years, 2 Months ago  
Sounds like there is no output at all coming from the scripts. Thats a bit strange.

Theres a file called "info.php" in the same folder where voicemail.php is located. Can u access this file with your browser and do you get the informational output about your php installation?
Enter code here   
Please note, although no boardcode and smiley buttons are shown, they are still useable
 
Report to moderator   Logged Logged  
  Reply Quote
#26
Re:XML no element found 11 Years, 2 Months ago  
Yes, tons!

Is there a particular portion of that file you'd like to examine?

I have verified that I've set those other two globals mentioned in the install docs correctly. I have also run the shell script and am calling it from voicemail.conf

Still no joy.

Thanks!
-Rob.
Enter code here   
Please note, although no boardcode and smiley buttons are shown, they are still useable
 
Report to moderator   Logged Logged  
  Reply Quote
#27
Re:XML no element found 11 Years, 2 Months ago Karma: 0  
Robert Goodyear wrote:
QUOTE:
Yes, tons!

Is there a particular portion of that file you'd like to examine?


No, main thing is that you can access the script and verified that the two php vars are set correctly. I have to admit i am a bit puzzled but the symptons were seeing here. I suggest the following:

- If the box is on the net you could give me a (read only) shell account on the box and ill check whats going wrong. If you can/want to do this send me the data using our contact form.

- locate the webserber logfile. Do a "tail -f" on the logfile, access voicemail.php with client or browser and post the result here.

- give me the neccessary data of a voicemail test account (context, voicemailboxname, password) and the URL to your voicemail.php script so i can try to debug this. Again, use the contact form and dont post the data here.

best regards,

Arnd<br><br>Post edited by: voiphead, at: 2006/10/08 23:52
Enter code here   
Please note, although no boardcode and smiley buttons are shown, they are still useable
 
Report to moderator   Logged Logged  
  Reply Quote
#28
Re:XML no element found 11 Years, 2 Months ago  
Here's the hit on the logfile:

Code:

68.4.72.187 - default/501 [08/Oct/2006:16:22:00 -0700] &quot;GET /voicemail/voicemail.php?action=listfoldercontent&amp;folder=INBOX HTTP/1.1&quot; 200 44 &quot;-&quot; &quot;Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7&quot; 68.4.72.187 - - [08/Oct/2006:16:22:00 -0700] &quot;GET /favicon.ico HTTP/1.1&quot; 404 291 &quot;-&quot; &quot;Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7&quot; 68.4.72.187 - default/501 [08/Oct/2006:16:22:04 -0700] &quot;GET /voicemail/voicemail.php?action=listfoldercontent&amp;folder=INBOX HTTP/1.1&quot; 200 44 &quot;-&quot; &quot;Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7&quot; 68.4.72.187 - - [08/Oct/2006:16:22:05 -0700] &quot;GET /favicon.ico HTTP/1.1&quot; 404 291 &quot;-&quot; &quot;Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7&quot;
And here is the errorlog
Code:

[client 68.4.72.187] PHP Warning: opendir(/var/spool/asterisk/voicemail/default/501/INBOX): failed to open dir: Permission denied in /var/www/html/voicemail/functions.php on line 318 [client 68.4.72.187] PHP Notice: Undefined variable: php_errormsg in /var/www/html/voicemail/functions.php on line 318 [Sun Oct 08 16:22:05 2006] [error] [client 68.4.72.187] File does not exist: /var/www/html/favicon.ico [Sun Oct 08 16:22:33 2006] [error] [client 192.168.2.192] File does not exist: /var/www/html/favicon.ico [Sun Oct 08 16:22:35 2006] [error] [client 192.168.2.192] File does not exist: /var/www/html/favicon.ico
Enter code here   
Please note, although no boardcode and smiley buttons are shown, they are still useable
 
Report to moderator   Logged Logged  
  Reply Quote
#29
Re:XML no element found 11 Years, 2 Months ago Karma: 0  
Robert Goodyear wrote:
[..]
And here is the errorlog

Code:

[client 68.4.72.187] PHP Warning: opendir(/var/spool/asterisk/voicemail/default/501/INBOX): failed to open dir: Permission denied in /var/www/html/voicemail/functions.php on line 318 [..]
[/quote] You still have access right problems. The script is not able to open the voicemail directory for user &quot;501&quot; as you can see in the error log. Please check the access rights and do a:
Code:

ls -ld /var/spool/asterisk ls -ld /var/spool/asterisk/voicemail ls -ld /var/spool/asterisk/voicemail/default ls -lR /var/spool/asterisk/voicemail/default/501
Which userid is the apache server using and how does the script look like youre using in voicemail.conf? Did you verifiy that the rights are really changed after a voicemail is left in a users voicemail box? Which system/components are you using on your asterisk server? best regards, Arnd
Enter code here   
Please note, although no boardcode and smiley buttons are shown, they are still useable
 
Report to moderator   Logged Logged  
  Reply Quote
Go to top Post Reply
Powered by FireBoardget the latest posts directly to your desktop

Warning: fopen(/opt/cms/ss/components/com_sef/cache/shCacheContent.php) [function.fopen]: failed to open stream: Permission denied in /opt/cms/ss/components/com_sef/shCache.php on line 112